Start a new topic

Diretta target not found from host PC

I am using an Afterdark Rosanna Diretta Network Bridge. I have been trying to get that recognized as Diretta target from my main Windows 11 PC. So far no success.

This PC has two ethernet adapters (NIC's). IPv6 is enabled (and metric set to 100) for the interface used for a direct connection to the Diretta target. This connection is not part of the home network.

find.exe gives the following result:

fe80::5f99:cc2c:856b:8757 ifno:8 [Ethernet] [Intel® Ethernet Connection (7) I219-V]
fe80::9960:58e3:361a:fa1d ifno:13 [Ethernet 2] [Intel® I211 Gigabit Network Connection]
1:Target: 0x7261447265746641 [fe80::72b3:d5ff:fec9:230%8] AfterDark._Bridge_1C9D
Version: 3_110_12
  1:Sink: 8 fe80::72b3:d5ff:fec9:230, 19644 MODEL_NAME
target de bug connect (exit:0)?

It shows two interfaces, and that there is a connection to the local network and between the host and the target, and alson that output is standby. However, there is still no sign of the target in Diretta's ASIO configuration tool, whichever ethernet interface I choose (one individual or AUTO).

The DAC is turned on and there is a good handshake between it and the target.

I did a clean install of my main Windows PC and also tried two other PC's. Two PCs have the problem described above. Only one PC, a NUC, works well, both with Windows and with Linux (GentooPlayer).

Any ideas? I am puzzled.

Can nobody help me? I now get the same problem on a new Beelink mini PC that I just installed.

Result of find.exe:

fe80::6beb:4408:c642:83fa ifno:6 [Diretta] [Realtek Gaming 2.5GbE Family Controller]

fe80::ca26:f826:e935:fe6f ifno:11 [Ethernet] [Lenovo USB Ethernet]

1:Target : 0x7261447265746641 [fe80::72b3:d5ff:fec9:230%6] AfterDark._Bridge_1C9D

 Version : 3_110_12

  1:Sink : 6 fe80::72b3:d5ff:fec9:230, 19644 Combo384 Amanero

target debug connect (exit:0)?

This looks good I think, as the target and Amanero board are found.

However, nothing shows up in the Diretta configuration tool.

Please advise.

Today, this problem got solved in a way that I did not expect. Installing an old version of the ASIO driver, namely DirettaASIOdriver_1_100_0.msi, the target is finally shown in the Diretta ASIO panel.

So apparently there is a bug in the last version of the Diretta ASIO driver.

Are the Diretta developers at all reading this forum?

Login to post a comment